[ASTUCE] Aide pour divers problèmes Heavybox

Tous les tutos concernant HyperLaunch 2.

Modérateurs: Nabubokon, Porko, Thesalan, Modérateurs

[ASTUCE] Aide pour divers problèmes Heavybox

Messagepar Nocta » 12 Nov 2013 - 03:56

Bon je l'avoue je suis tombé amoureux du projet lancé par Heavyarms, du coup j'ai collectionné les bidouilles et aides trouvées à droite et à gauche (sur tous les forums que j'ai trouvé parlant du projet en fait... :o  ) pour résoudre les différents problèmes que l'on peut rencontrer avec cette box. Et puis quelqu'un sur Neo-Arcadia vient de faire la remarque qu'il faudrait les centraliser, donc les voici ! :D  
Si une personne est gêné par le fait que je cite son explication ou sa solution, qu'il n'hésite pas à me contacter.

Donc les voici, une par une pour plus de clarté (avec le titre de chaque message indiquant le problème concerné pour une recherche rapide).
N'hésitez pas à en rajouter d'autre si j'en ai laissé s'échapper (ha bon... :evil:  ).
Je complèterai au fur et à mesure.

Enjoy!
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

Image tremblotante sur ZSNES

Messagepar Nocta » 12 Nov 2013 - 03:57

Pour ne plus avoir l'image tremblotante sur ZSNES:

Lancer l'emu directos depuis le dossier, modifier la résolution custom 41 (l'avant dernière ligne, il suffit de compter pour être sûr) en 352x256 puis désactivé le triple buffering sur l'onglet d'après (sinon j'avais un voile bizarre que j'ai aussi sous Mame surtout avec la Neo Geo)

Ensuite quitter l'emu, dans le dossier Hyperspin\Modules\Super Nintendo il y a le fichier Super Nintendo.ahk

J'ai modifié les lignes:

Fullscreen=true

Stretch=true

resx=352

resy=256

plus en dessous il y a 3 lignes "video mode" ou j'ai modifié la valeur par 41 (la resolution custom utilisée dans ZSNES)

Après ça... Nickel
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

impossible de lancer un jeu

Messagepar Nocta » 12 Nov 2013 - 03:57

Si impossible de lancer un jeu:
pour y pallier j'ai ouvert le fichier ini de groovymame et j'ai mis ddraw à la place de d3d.
Après cela je me suis aperçu que les jeux ( son et image) allaient à vitesse grand V donc injouable.
J'ai un peu trifouillé le fichier ini de groovymame et c'est en mettant la valeur1 au triplebuffer que j'ai retrouvé une vitesse de jeu et de son normale.
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

jeux en accéléré

Messagepar Nocta » 12 Nov 2013 - 04:00

Essayer la touche F10 dans le jeu
Ou Throttle à 1 dans Mame.ini
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

modifier résolution KEGA si trop élevée

Messagepar Nocta » 12 Nov 2013 - 04:02

Pour modifier la résolution de KEGA, il faut que tu ailles dans le Fusion.ini, dans le passage "Expert Mode" et que tu remplaces les modelines de l'ini par celle ci et activer le Vsync une fois revenu sur l'émulateur :

Code :
RefreshRate60Hz=60
RefreshRate50Hz=50
UseExpertModes=1
UseAutoSwitching=1
MinSwitchDelay=100
Mode256x240=256,240,60,50,256,240
Mode256x480=256,480,60,50,256,480
Mode320x240=320,240,60,50,320,240
Mode320x480=320,480,60,50,320,480
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

pas de hs en 15khz

Messagepar Nocta » 12 Nov 2013 - 04:04

Si hyperspin ne se lance pas en 15khz:
trop de modelines dans le vmmaker.ini ( il y en a 120 d'origine).

Il faut:
-éditer ce fichier avec notepad
-remplacer 120 par 90
- tu fermes le fichier en enregistrant bien
- tu lances vmmaker
-à la fin tu redémarres ta bécanes et ça devrait fonctionner.


Dans le VmMaker.ini

ModeTableMethod_XML = tu met 2 (cela crée les magics résolutions) c'est un hack pour hyperspin mais uniquement en d3d ou 1 (si on utilises les modelines proposées par huRRi en ddraw)

Si tu met 1 cela génère autant de modelines que groovymame à besoin ou bloque a la limite fixé (ici 90)
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

ralentissement shoots cave

Messagepar Nocta » 12 Nov 2013 - 04:04

Pour les shoot cave, utiliser MAMEUIFX32 et ça tourne au poil, sans ralentissement, mais pas en vrai résolution. :cry:  
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

touche sortie d'émulateur

Messagepar Nocta » 12 Nov 2013 - 04:05


Alors pour changer ta touche de sortie d'émulateur et retourner sous Hyperspin :

- Dans le dossier Settings, ouvre "Settings.ini"
- Dans ce "Settings.ini", tu descends jusqu'a arriver dans la catégorie "HyperLaunch"
- Dans "HyperLaunch", tu as une valeur nommé : exit_emulator_key=~Esc
- Tu as maintenant juste a remplacer Esc par la touche de ton choix.

Cette valeur te sert à regler le bouton qui va couper HyperLaunch pour te faire revenir sur Hyperspin et pas simplement quitter l'émulateur. Quand tu presses Esc pour quitter un jeu, tu ne fermes pas toi même l'émulateur ! En réalité tu dis à Hyperlaunch de couper l'émulateur, de démonter la rom et de revenir sous Hyperspin en premier plan.

------------------

Pour la touche de sortie dans le module de la Megadrive, essayer de trouver une ligne avec "ESC" et change la valeur avec les touches désirées.

Pour la PC Engine, la touche ESC qui est normalement pour quitter est remplacé par la touche F1, pour être compatible avec HyperLaunch.
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

trucs astuces cave

Messagepar Nocta » 12 Nov 2013 - 04:06

aller dans le dossier Emulators/Cave et ouvrir le mame.ini et sur la ligne:

- keepaspect mettre sur "1"

Ensuite aller dans le dossier Emulators/Cave/ini et ouvrez chaques ini (qui correspondent à tel ou tel jeux) pour lequel la vitesse est excessive et sur la ligne:

- synchrefresh mettre sur"0"
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

trucs astuces shmupmame

Messagepar Nocta » 12 Nov 2013 - 04:09

Voici la liste des jeux qui ne sont pas affichés correctement:

Batrider
Batsugun
Battlebakraid
Blue hawk
brave blade
Cyvern
Desert War
Dodonpachi beestorm
Dogyuun
Donkey kong: pas de possibilité de créditer
Donkey kong junior: pas de possibilité de créditer
Gaiapolis
Gardians storm est carrément à l’envers, pas trouver le moyen de modifier...
Gunbird 1 et 2
Gunlock
Kingdomgranprix
Macrossplus: son faible
Mad gear
Raiden fighters
Raden fighter 2
Raiden fighter jet
Rapid hero
Samurai ace
Sapce invaders 95
Strikers 1945
Strikers 1945 2
Strikers 1945 3
Truxton 2
Valkyrie no densetsu: la rom est présente dans le dossier Rom/Mame il suffit juste de la déplacer dans le dossier Rom/Shmupmame
Varth
Vasara
Vasara 2

Il faut juste appuyer sur "tab" aller dans "video mode" et sélectionner "none" dans l'onglet "rotante"

Pour désactiver le message de confirmation:

Shmupmame/mame.ini modifiez la ligne: skip_gameinfo 1
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

vidéo prince of persia ne fonctionne pas

Messagepar Nocta » 12 Nov 2013 - 04:11

Pour Prince of Persia, il y a un signe "%" dans le titre et le module ne l'accepte pas apparemment, il faut renommer l'XML, jeu et ses médias en "Prince of Persia (E) [T+Fre100pourcent_Tbex]"
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

Fusion ne s'ouvre pas

Messagepar Nocta » 12 Nov 2013 - 04:12

Dans la partie "Graphics Compatibility Options" du fichier fusion.ini, essayez de changer ces paramètres une à une pour voir si cela change quelque chose, moi j'ai mis cela et ca marche bien.

Code:
;---------------------------------
; Graphics Compatibility Options
;---------------------------------

ForceCompatibleGFX=0
CompatibleGFXOpt=0
EnhancedGFXOpt=0
ForceFullScreen32=0
VistaAeroIgnore=0
VistaNoWndVSync=1
DebugFlags=0,0,2,2
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

affichage correcte shmupmame si full screen

Messagepar Nocta » 12 Nov 2013 - 04:12

Pour l'affichage correct des jeux verticaux sur écran horizontal:

- Allez dans le dossier HYPERSPIN/EMULATEURS/SHMUPMAME/, lancer l'éxecutable de configuration de l'émulateur.
Dans option/Options d'affichage, choisissez KEEP ASPECT RATIO (attention de quitter le logiciel proprement cliquer sur l'onglet Fichier, puis sur QUITTER, afin qu'il sauvegarde les modifications).
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

jeu valkyrie mal placé

Messagepar Nocta » 12 Nov 2013 - 04:13

Aller dans ...\Hyperspin\Roms\Mame
chercher la rom "Valkyrie.zip"
la couper (ctrl+x) et la coller(ctrl+v) dans .../Hyperspin\Roms\ShmupMame

(valkyrie ne se trouve ni dans la database mame et les thèmes mame, donc il parait illogique que sa rom s'y trouve)
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

paramètres vmmaker pour le 224p

Messagepar Nocta » 12 Nov 2013 - 04:19

Pour résoudre le problème des modelines qui ne descendent pas en dessous de 240p c'est très simple aller dans Vmmaker.ini puis aux lignes suivantes :


; Minimum resolution values (these will be used instead of lower values)

XresMin_XML = 240
YresMin_XML = 240
YresRound_XML = 4

Remplacer le YresMin_XML = 240 par YresMin_XML = 160.
Image
Avatar de l’utilisateur
Nocta
Connaisseur
Connaisseur
 
Messages: 350
Inscription: 15 Oct 2013 - 01:00

Re: [Heavybox] Aide pour divers problèmes

Messagepar huRRi » 14 Nov 2013 - 07:39

Salut ;)

Alors moi j'ai eu un soucis qui m'a valu quelques jours d'arrachage de cheveux !

Hyperspin planté après avoir démarré : black screen puis ça remarchais ou bien BSOD.
Par ailleurs, ça planté tellement méchant que ça désactivait l'accélération matérielle de ma carte graphique (adieu direct 3D) donc pas de merdouilles en perspective.

J'avais d'abord pensé au problème connu du trop grand nombre de modelines installées qui font planter Hyperspin.

Le problème venait en faite des vidéos preview.

Je les ai toutes ré-encodé en "FLV" y compris celles déjà en "FLV" avec l'outil gratuit "Freemake Video Converter".

Depuis plus un seul plantage.

En espérant que ça puisse aider certains.
Image
Avatar de l’utilisateur
huRRi
Connaisseur
Connaisseur
 
Messages: 267
Inscription: 04 Nov 2013 - 00:00

Re: [Heavybox] Aide pour divers problèmes

Messagepar chaff » 01 Mar 2014 - 14:23

Merci beaucoup, ça m'a bien aidé !
Avatar de l’utilisateur
chaff
noob
noob
 
Messages: 1
Âge: 33
Inscription: 15 Aoû 2013 - 01:00

Re: [Heavybox] Aide pour divers problèmes

Messagepar NikoSSinio » 28 Avr 2014 - 21:46

MERCI D’ARRÊTER DE SPAMMER TOUS LES POSTS DU FORUM. DarkEagle37
Image
Avatar de l’utilisateur
NikoSSinio
Connaisseur
Connaisseur
 
Messages: 348
Âge: 43
Inscription: 13 Avr 2014 - 01:00
Localisation: Picardie (80)

Re: [Heavybox] Aide pour divers problèmes

Messagepar NikoSSinio » 28 Avr 2014 - 22:28

?? pourquoi supprimer mes messages ??
je cherche juste de l'aide
Image
Avatar de l’utilisateur
NikoSSinio
Connaisseur
Connaisseur
 
Messages: 348
Âge: 43
Inscription: 13 Avr 2014 - 01:00
Localisation: Picardie (80)

Re: [Heavybox] Aide pour divers problèmes

Messagepar DarkEagle37 » 28 Avr 2014 - 22:36

?? pourquoi supprimer mes messages ??
je cherche juste de l'aide
Il me semble que tu a déjà demandé de l'aide ici, je penses qu"un post suffit :!:
Image
Nocta a écrit:La Team HFS ? Ah bah c'est une communauté de types qui dorment 2h par nuit, tournent à 4 g de coke par jour et font du meilleur boulot que les boites pros, le tout sur leur temps libre. Ensuite ils partagent tout gratos et font même le service après-cadeau, ça t'intéresse ? :shock:
Avatar de l’utilisateur
DarkEagle37
Modérateur
Modérateur
 
Messages: 3329
Âge: 22
Inscription: 07 Mar 2013 - 00:00
Localisation: Tours (37)



Retourner vers Tutos pour HyperLaunch 2



Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité