[EN COURS] Problème affichage après inutilisation prolongé

Un problème que vous ne pouvez classer dans aucune des autres sections?

Modérateurs : Porko, Modérateurs

Répondre
Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

[EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 10 avr. 2021 - 07:54

Bonjour à tous !

Voilà j'ai un soucis apparemment peu commun...
J'ai un Rpi 4b branché via un adaptateur micro hdmi vers VGA qui lui est relié à un câble VGA vers écran 4/3 Dell.
Je joue sur Recalbox dessus, qui fonctionne très bien !

Le soucis c'est quand je ne l'allume pas pendant une grosse journée. J'allume mon écran et met en route mon RPi et là je n'ai pas d'affichage. Juste le son.
Pour remédier au problème je suis obligé de débrancher le micro hdmi puis le rebrancher. Si je débranche le VGA pour le rebrancher ensuite cela ne change rien !
Une fois le soucis réglé je peux lancer et relancer recalbox je n'aurais plus de soucis !
Mais c'est juste quand je le laisse éteint un long moment.

Help me please ! :( :(

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 4161
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 578 fois
A été remercié : 710 fois
Contact :

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par camarade35 » 10 avr. 2021 - 08:40

Bonjour,

alors une petite recherche GG : https://www.raspberrypi.org/forums/view ... hp?t=34061
et pour faire simple il faut forcer le HDMI dans le fichier config.txt

Code : Tout sélectionner

hdmi_force_hotplug=1
Bonne journée (et un p'tit coucou dans la section Prez, c'est toujours sympa ;) )
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 10 avr. 2021 - 09:16

Bonjour a toi camarade35 (oups désolé pour la prez, c'est fait ! 😉)
Je vais essayer ton astuce en rentrant mais pourquoi celà "bug" après une inutilisation prolongé ?! J'arrive pas à faire le rapprochement avec le forcement hdmi.

Bonne journée à toi aussi !

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 4161
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 578 fois
A été remercié : 710 fois
Contact :

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par camarade35 » 10 avr. 2021 - 10:41

Re, alors je ne pourrais pas répondre au pourquoi mais peut-être simplement que la sortie HDMI n'est pas celle par défaut ou voir que dans le fichier conf un autre est choisi.
Le fait de deb/reb doit activer la sortie. Tout ça ne reste qu'une supposition
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 10 avr. 2021 - 14:07

Re, tu vas surement m'insulter mais je n'y connais pas grand chose : est ce que je dois RAJOUTER cette commande dans Customs config du fichier config txt ou est ce que je doit décommenter une ligne ?

voici mon fichier Config txt :

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

disable_overscan=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.
#hdmi_drive=2

config_hdmi_boost=0

# Force hdmi while the tv can take time before sending the signal on the hdmi output
hdmi_force_hotplug=1

# Uncomment if you have a black screen issue
#hdmi_ignore_hotplug=1

# uncomment for composite PAL - Uncomment if you have a black screen issue
#sdtv_mode=2

# uncomment for lirc-rpi
#dtoverlay=lirc-rpi

# enable fake-kms overlay
# possible alternatives are
# * vc4-kms-v3d
# * vc4-kms-v3d-pi4
dtoverlay=vc4-fkms-v3d

# allow only one framebuffer (the one marked 0, closest to the power input)
max_framebuffers=1

# disable 4k 60hz - enabling can cause random freezes
#hdmi_enable_4kp60=0

# total amount of GPU memory
gpu_mem=448

###########################
# do not remove this line !
include recalbox-config.txt

# custom config
[all]


Merci à toi en tout cas pour ton aide ! :D

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 4161
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 578 fois
A été remercié : 710 fois
Contact :

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par camarade35 » 11 avr. 2021 - 10:19

Je vais prendre ton message et le commenter mais c'est quand même de l'anglais basique dans le fichier de conf
Zuviel a écrit :
10 avr. 2021 - 14:07
Re, tu vas surement m'insulter mais je n'y connais pas grand chose : est ce que je dois RAJOUTER cette commande dans Customs config du fichier config txt ou est ce que je doit décommenter une ligne ?

voici mon fichier Config txt :

# uncomment if you get no picture on HDMI for a default "safe" mode --> ton soucis semblerait-il
#hdmi_safe=1 --> enleves le #

disable_overscan=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.
#hdmi_drive=2

config_hdmi_boost=0

# Force hdmi while the tv can take time before sending the signal on the hdmi output --> la fameuse ligne mais qui est déjà ok
hdmi_force_hotplug=1 --> rien à faire sur celle-ci

# Uncomment if you have a black screen issue --> deuxième possibilité
#hdmi_ignore_hotplug=1 enleves le #

# uncomment for composite PAL - Uncomment if you have a black screen issue
#sdtv_mode=2

# uncomment for lirc-rpi
#dtoverlay=lirc-rpi

# enable fake-kms overlay
# possible alternatives are
# * vc4-kms-v3d
# * vc4-kms-v3d-pi4
dtoverlay=vc4-fkms-v3d

# allow only one framebuffer (the one marked 0, closest to the power input)
max_framebuffers=1

# disable 4k 60hz - enabling can cause random freezes
#hdmi_enable_4kp60=0

# total amount of GPU memory
gpu_mem=448

###########################
# do not remove this line !
include recalbox-config.txt

# custom config
[all]


Merci à toi en tout cas pour ton aide ! :D
Voilà pour moi ;) et je ne suis pas un pro non plus, juste de la lecture ^^
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 11 avr. 2021 - 18:10

J'ai testé les 2 options ça n'a rien changé... peut être l'adaptateur micro hdmi vers VGA qui est foireux ?

Je précise que quand je débranche et rebranche l'adaptateur j'ai l'image mais la qualité de l'image est "mauvaise". Il faut complètement redémarrer le RPi pour que la résolution soit correcte.

Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 11 avr. 2021 - 18:12

Et en Hdmi je n'ai aucun soucis

Avatar de l’utilisateur
Zuviel
noob
noob
Messages : 7
Inscription : 10 avr. 2021 - 06:09
A remercié : 3 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par Zuviel » 12 avr. 2021 - 12:05

Help?

Avatar de l’utilisateur
wildpumpk1n
Virtuose
Virtuose
Messages : 1060
Inscription : 04 févr. 2018 - 19:01
Localisation : Région Parisienne
A remercié : 241 fois
A été remercié : 182 fois

Re: [EN COURS] Problème affichage après inutilisation prolongé

Message par wildpumpk1n » 13 avr. 2021 - 12:25

Et si jamais par hasard (je savais meme pas que recalbox était sur rpi4) tu refaisais une image rapidement.
Tu saves la tienne au pire et en refait une autre rapidement pour voir si ca vient d'un souci matériel ou logiciel?
Tu as essayé sur un autre périphérique HDMI voir si tu avais le souci?

Bref, test croisé pour voir.
Image-Image-Image
#Cid2nice"Mais y'a la planche Naomi en sakura véritable et vénérable du Japon"

Répondre

Revenir à « Divers »