[TUTO] HyperTheme Partie 2, création pas à pas d'un thème

Tous les tutos concernant les logiciels d'édition d'image, vidéo et HyperTheme.

Modérateurs : Thesalan, Nabubokon, Porko, Modérateurs

Avatar de l’utilisateur
wstudio
Amateur
Amateur
Messages : 45
Inscription : 01 août 2015 - 22:03
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par wstudio » 20 sept. 2015 - 22:43

oui, je l'ai lu. le tuto explique bien les commandes de bases, mais pour les vidéos ca traite du flv et non pas comment intégrer un .mp4

Avatar de l’utilisateur
moustic
Administrateur
Administrateur
Messages : 6528
Inscription : 23 juil. 2014 - 01:00
Localisation : Saint Jean Rohrbach
A remercié : 225 fois
A été remercié : 532 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par moustic » 20 sept. 2015 - 22:57

L'intégration du mp4 est identique au flv cela marche de la même façon !
Image

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 3963
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 461 fois
A été remercié : 622 fois
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par camarade35 » 21 sept. 2015 - 06:34

moustic57 a écrit :L'intégration du mp4 est identique au flv cela marche de la même façon !
Oui et non. :) (mode normand)
En fait, Hyperthème ne voudra pas voir une video.mp4 en l'appelant directement, néanmoins, Hyperspin la chargera.
L'astuce est de changer l'extension de ta vidéo de mp4 en flv.
Perso, je garde une vidéo en 640x480 avec l'extension ;FLV et je ne travaille qu'avec celle-ci. Ensuite, suivant le nom du jeu/system, Hyperspin appelera la vidéo qu'il faut
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
moustic
Administrateur
Administrateur
Messages : 6528
Inscription : 23 juil. 2014 - 01:00
Localisation : Saint Jean Rohrbach
A remercié : 225 fois
A été remercié : 532 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par moustic » 21 sept. 2015 - 07:20

Ben oui mais j'avais pas compris la question comme ca en fait :oops:

Désolé
Image

Avatar de l’utilisateur
wstudio
Amateur
Amateur
Messages : 45
Inscription : 01 août 2015 - 22:03
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par wstudio » 21 sept. 2015 - 20:56

Hello, Merci pour cet éclaircissement.
Mais du coup ce que je comprends pas c'est que par exemple dans la HFSbox les videos sont des .mp4 dans les repertoire /media/<systeme>/video.
du coup comment sont-elles chargée par hypertheme ??
dans les thèmes default.zip, il y a un fichier video.png, dont j'ai lu qu'il permettait de faire la passerelle...
Ma question est comment utiliser ce fichier dans hypertheme ?

Avatar de l’utilisateur
andric31
Maître
Maître
Messages : 4447
Inscription : 14 sept. 2014 - 01:00
Localisation : Entre mer et montage
A remercié : 557 fois
A été remercié : 446 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par andric31 » 21 sept. 2015 - 21:02

Pas par hypertheme puisque il prend pas les mp4. Hyperspin prend les coordonner de l'emplacement vidéo (créer par hypertheme) est c'est hyperspin qui prend en charge le flux.
Video.png c'est le cadre.

Avatar de l’utilisateur
wstudio
Amateur
Amateur
Messages : 45
Inscription : 01 août 2015 - 22:03
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par wstudio » 21 sept. 2015 - 22:30

@Andric31 , Ok mais comment on insère le cadre via hypertheme ?

Avatar de l’utilisateur
andric31
Maître
Maître
Messages : 4447
Inscription : 14 sept. 2014 - 01:00
Localisation : Entre mer et montage
A remercié : 557 fois
A été remercié : 446 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par andric31 » 21 sept. 2015 - 23:12

Yo,
Tu le fait pas par Hypertheme,
sur le bureau tu fait un déposer/coller de video.png dans le zip et tu auras le cadre sur la vidéo

Je fait pas de thèmes alors il y à peut être d'autres soluce

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 3963
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 461 fois
A été remercié : 622 fois
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par camarade35 » 22 sept. 2015 - 07:26

@wstudio : dans hyperthème, tu as tous les icones en haut. à côté de vidéo, il y en a un autre.
Tu cliques dessus et tu verras à gauche une option à cocher (image) et là il va te demander de choisir le fichier.
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
wstudio
Amateur
Amateur
Messages : 45
Inscription : 01 août 2015 - 22:03
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par wstudio » 22 sept. 2015 - 08:11

@andric : j'avais essayé ca au début, mais si on fait ca le video.png n'est pas indexé dans le xlm et hypertheme retourne une erreur de parsing
@camarade35 : merci !! il faut une video pour inserer un frame, du coup j'ai pris le "no video.flv" dans le repertoire frontend.
J'ai sauvegarder le thème sous "default.zip" que j'ai mis dans /hyperspin/media/<systeme>/Themes/ .
le Thème s'affiche bien quand je selectionne les jeux dans la wheel <systeme> , mais pas les videos.
Elles sont dans le répertoire correspondant /hyperspin/media/<systeme>/video/ .
j'ai probablement loupé une marche, mais je ne vois pas où :)

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 3963
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 461 fois
A été remercié : 622 fois
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par camarade35 » 22 sept. 2015 - 19:03

attention, si tu fais un thème défaut, il faut choisir l'option dans hyperthèmes (en bas).
Ensuite, suivant le nom du jeu, l'appel de la vidéo se fera si celle-ci porte le même nom que la "ROM"
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
wstudio
Amateur
Amateur
Messages : 45
Inscription : 01 août 2015 - 22:03
Contact :

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par wstudio » 23 sept. 2015 - 20:12

Hello

Alors, dans l'ordre :

1) j'ai checké dans hypertool que les noms des video matchaient bien la database --> OK

2) voici ce que j'ai dans Hypertheme :

Image


3) le zip résultant (defautl.zip) contient :
Artwork.png
background.png
Video.png
Theme.xml

4) Le theme.xml contient :

<Theme>
<video w="556.3"
h="417.3"
x="329.95"
y="472"
r="0"
rx="0"
ry="0"
below="false"
overlaybelow="false"
overlayoffsetx="0"
overlayoffsety="0"
forceaspect="none"
time="1"
delay="0.5"
bsize="0"
bsize2="0"
bsize3="0"
bcolor="0"
bcolor2="0"
bcolor3="0"
bshape="false"
type="none"
start="none"
rest="none"/>
<artwork2 x="504" y="87" r="0" time="0.5" delay ="0" type="grow" start="none" rest="none"/>
<artwork4 x="890" y="709" r="0" time="0.5" delay ="0.3" type="none" start="bottom" rest="spin slow"/>
</Theme>

mais les video n'apparaissent tjs pas.

Un élément intéressant : quand je copie un thème default d'un autre système , je n'ai pas de video non plus ... ce qui semblerait indiquer que le probleme est peut être ailleurs ?

Avatar de l’utilisateur
cochesebox
Connaisseur
Connaisseur
Messages : 215
Inscription : 15 sept. 2015 - 09:13
Localisation : pas loin du clavier
A remercié : 17 fois
A été remercié : 9 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par cochesebox » 03 nov. 2015 - 16:32

excusez-moi je ne fais que passer.... juste pour dire merci pour ce tuto car il envoie du bois. et merci a silmeria grâce a qui j'ai été focalisé sur l'inspiration dès le début :evil: !! et désolé wstudio je ne peut pas t'aider pour le moment...

Avatar de l’utilisateur
cochesebox
Connaisseur
Connaisseur
Messages : 215
Inscription : 15 sept. 2015 - 09:13
Localisation : pas loin du clavier
A remercié : 17 fois
A été remercié : 9 fois

Re: [TUTO] HyperTheme Partie 2, création pas à pas d'un thèm

Message par cochesebox » 04 nov. 2015 - 17:25

wstudio a écrit : mais les video n'apparaissent tjs pas.

Un élément intéressant : quand je copie un thème default d'un autre système , je n'ai pas de video non plus ... ce qui semblerait indiquer que le probleme est peut être ailleurs ?
C'est bon j'ai réussi mes thèmes (que je rend dispo bientôt) je peux te répondre ^^
qd tu zippe ton theme, la vidéo se transforme en png... du coup tu dois mettre ta video .flv dans le dossier vidéo (media/ton emulateur/video), et la ça marche.

ps : @wstudio, ah désolé je viens de relire tes anciens posts et du coup je vois que j'ai mal compris ta question.... pour le coup je peux tjs pas t'aider... car je comprend meme pas le probleme en fait en y réfléchissant bien

Répondre

Revenir à « Tutos Graphisme et Edition »