[RESOLU]MESS, problème de lancement de certaines roms SCV

Ici se règle les problèmes concernant une configuration Hyperspin tournant sous HyperLaunch 3.

Modérateurs : Porko, Modérateurs

Avatar de l’utilisateur
erik78
noob
noob
Messages : 3
Inscription : 15 juin 2014 - 01:00

MESS, problème de lancement de certaines roms SCV

Message par erik78 » 01 mai 2018 - 15:05

bonjour,

j'ai un petit soucis pour lancer certaines roms epoch super cassette vision, le problème ne se rencontre que sur les roms qui contiennent plusieurs fichiers (désolé si je m'explique mal).

ex: le jeux kungfu road

nom de l'archive: kungfurd.zip
contenu: kungfurd.0 et kungfurd.1

j'ai bien le bios scv dans le répertoire roms de mess, les roms correspondent bien au fichier hash correspondant
quand je le lance par hyperlaunch3 , mess me charge uniquement le fichier kungfurd.0 ce qui me donne comme résultat, une émulation foireuse car rom incomplète, voir un black screen
en lançant mess directement et essayant de charger le zip normalement, il me le vois comme un répertoire, et je ne peux que charger kungfurd.0 ou kungfurd.1
le seul moyen que j'ai trouve de lancer correctement ces roms manuellement depuis mess, c'est depuis la fonction software list, qui là me charge bien la rom complète.

mais je n'arrive pas à trouver comment faire avec hyperlaunch/hyperspin. j'utilise le module de mess fourni avec hyperspin, en vérifiant le log, la commande lancé par le script est la suivante:

F:\Hyperspin\Emulators\MESS\mess.exe scv -cart "F:\Hyperspin\Emulators\Epoch Super Cassette Vision\roms\kungfurd.zip" -nowindow -video d3d -nouse_bezels -nouse_overlays -nouse_backdrops -skip_gameinfo

quelqu'un aurait t'il déjà rencontré ce souci?
Dernière modification par erik78 le 13 mai 2018 - 06:47, modifié 1 fois.

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 3981
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 474 fois
A été remercié : 641 fois
Contact :

Re: MESS, problème de lancement de certaines roms SCV

Message par camarade35 » 01 mai 2018 - 19:57

Salut @erik78 y'a un truc bizarre, normalement les scv c'est du .bin

voir ici : " onclick="window.open(this.href);return false;

mais ailleurs on signale du .zip
Donc je peux te conseiller d'essayer la commande directe via le dossier de l'émulateur
ouvrir l'invite de commande dans le dossier de l'ému et ensuite taper ce qu'il y a d'écrit mais juste ça

Code : Tout sélectionner

mess.exe scv -cart "F:\Hyperspin\Emulators\Epoch Super Cassette Vision\roms\kungfurd.zip"
citation supplémentaire
un gars sur la toile a écrit :You need the bios scv.zip which contains the files epochtv.chr and upd7801g.s01
and the Default Command-Line Params are
scv -cart

Code : Tout sélectionner

mame.exe scv -cart "chemin\complet\du\jeu.zip"
Edit : ça marche très bien avec MAME 0.196 avec la commande suivante
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
erik78
noob
noob
Messages : 3
Inscription : 15 juin 2014 - 01:00

Re: MESS, problème de lancement de certaines roms SCV

Message par erik78 » 01 mai 2018 - 20:56

merci pour ta réponse camarade35 ,
j'ai bien le bon bios (validé par mess) dans le répertoire roms de mess
pour l'extension.bin, je suis d'accord avec toi, mais si tu regarde le fichier hash scv.xml de mess, tu verras qu'il y a 3 jeux constitués de 2 fichier par archive (kungfu road, doraemon et starspeeder)

quand je lance cette commande : mess.exe scv -cart "F:\Hyperspin\Emulators\Epoch Super Cassette Vision\roms\kungfurd.zip"
j'ai bien le jeu qui se lance, mais pas de musique d'intro, quand je regarde le fichier qui est chargé c'est le fichier avec pour extension .0 qui est chargé

après quelques essais sur mess seulement (roms dans le repertoire de mess) en lancant cette commande: "mess.exe scv -cart kungfurd" le jeu se lance sans aucun soucis.
à partir de ce constat, je pense que je vais m'orienter vers la modif du script ahk de mess afin de lancer cette commande:
"mess.exe -rompath "roms;F:\Hyperspin\Emulators\Epoch Super Cassette Vision\roms" scv -cart kungfurd"

edit: quand je lance la commande ci-dessus (les roms ne sont plus dans le repertoire de mess, juste le bios scv), les jeux se lancent bien, je vais voir comment modifier le script, j'y connais rien en ahk, mais je devrais m'en sortir
Dernière modification par erik78 le 01 mai 2018 - 21:00, modifié 1 fois.

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 3981
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 474 fois
A été remercié : 641 fois
Contact :

Re: MESS, problème de lancement de certaines roms SCV

Message par camarade35 » 01 mai 2018 - 20:59

@erik78 : mess et mame sont fusionnés : prend le mame 0.196 ou 0.197 ça marche

Moi tout fonctionne

Allez, go Vierzon, pause forum pendant une semaine ;)
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
sp0ke
noob
noob
Messages : 5
Inscription : 29 août 2019 - 22:42

Re: [RESOLU]MESS, problème de lancement de certaines roms SCV

Message par sp0ke » 02 déc. 2019 - 12:54

Bonjour,

Je reprends le fil ce topic car je tombe exactement sur le même problème qu' erik78.
La version de MAME que j'utilise est la 0.216 (No nag), le fichier scv.xml se trouve bien dans le repertoire (hash) de MAME, sauf qu'il ne fonctionne pas avec HyperSpin alors qu'il fonctionne parfaitement dans MAME lancé seul sans HyperSpin.

Comment peut-on arranger cela, y a t-il une modification à effectuer dans un quelconque fichier de HyperSpin ou RocketLauncher.
Si quelqu'un connait la solution je suis preneur, merci par avance.



@++

Avatar de l’utilisateur
sp0ke
noob
noob
Messages : 5
Inscription : 29 août 2019 - 22:42

Re: [RESOLU]MESS, problème de lancement de certaines roms SCV

Message par sp0ke » 03 déc. 2019 - 19:26

Hello la foule, :D

Personne pour m'aider un tout petit peu plz :cry:



@++

Répondre

Revenir à « Aide sur RocketLauncher »