[ZSPIN] Beta-test

Download section. You can grab the latest zspin beta release here.

Modérateurs : vik, Modérateurs

Avatar de l’utilisateur
Porko
Modérateur
Modérateur
Messages : 2018
Inscription : 02 févr. 2014 - 00:00
Localisation : 26700
A remercié : 249 fois
A été remercié : 378 fois

Re: [ZSPIN] Beta-test

Message par Porko » 17 sept. 2015 - 17:41

As tu fais remonter le problème? Sur le premier message de ce sujet il y a un googledoc pour ça.

Si tu mets le theme avec c'est encore mieux car vik pourra voir d'où ça vient et peut être corriger

Edit: verifies que le problème ne soit pas déjà répertorié... Les doublons c'est pas cool

Avatar de l’utilisateur
XxTookie38xX
Initié
Initié
Messages : 114
Inscription : 22 juin 2014 - 01:00
A remercié : 2 fois
A été remercié : 1 fois

Re: [ZSPIN] Beta-test

Message par XxTookie38xX » 17 sept. 2015 - 18:03

Porko a écrit :Zspin est un frontend, en gros il remplace hyperspin.exe il transmet les infos nécessaire à RL
Il n'y a pas besoin de le renseigner dans RL.

Pour l'installation il y a un WIKI en cours de rédaction https://github.com/HFScode/zspin/wiki


Pour répondre précisément à ta question il n'y a pas de module pour Zspin parce qu'il n'en a pas besoin prends le profil hyperspin
En gros touches à rien
Ok ça roule, mais du coup ça reste quand même tributaire d'hyperspin dans RL. Je vais essayer de plancher sur cette histoire de plugin et lancer un appel a djvj

Comme ça Zspin sera vraiment indépendant d'hyperspin

Avatar de l’utilisateur
camarade35
Maître
Maître
Messages : 4003
Inscription : 05 sept. 2013 - 01:00
Localisation : Chevaigné
A remercié : 485 fois
A été remercié : 655 fois
Contact :

Re: [ZSPIN] Beta-test

Message par camarade35 » 17 sept. 2015 - 18:12

Zspin a été fait de façon à être compatible avec le module HyperSpin de RocketLauncher, de ce fait, rien besoin de faire, si ce n'est changer le nom du module à la rigueur.
Voilà.


j'ai dis de la merde, Viiiikkkk !!!
préservation du patrimoine vidéoludique et de notre planète

Avatar de l’utilisateur
vik
Connaisseur
Connaisseur
Messages : 404
Inscription : 01 janv. 1970 - 03:34
Localisation : Evreux
A remercié : 16 fois
A été remercié : 266 fois
Contact :

Re: [ZSPIN] Beta-test

Message par vik » 17 sept. 2015 - 18:28

ouais faut que je refasse un plugin RL

Avatar de l’utilisateur
Meth
Administrateur
Administrateur
Messages : 4396
Inscription : 19 oct. 2012 - 01:00
Localisation : Conflans-en-Jarnisy
A remercié : 880 fois
A été remercié : 1431 fois
Contact :

Re: [ZSPIN] Beta-test

Message par Meth » 17 sept. 2015 - 18:30

XxTookie38xX a écrit :
Porko a écrit :Zspin est un frontend, en gros il remplace hyperspin.exe il transmet les infos nécessaire à RL
Il n'y a pas besoin de le renseigner dans RL.

Pour l'installation il y a un WIKI en cours de rédaction https://github.com/HFScode/zspin/wiki


Pour répondre précisément à ta question il n'y a pas de module pour Zspin parce qu'il n'en a pas besoin prends le profil hyperspin
En gros touches à rien
Ok ça roule, mais du coup ça reste quand même tributaire d'hyperspin dans RL. Je vais essayer de plancher sur cette histoire de plugin et lancer un appel a djvj

Comme ça Zspin sera vraiment indépendant d'hyperspin

Nous avons essayé de contacté Djvj et sommes en attente de sa réponse.

Quoi qu'il en soit le plugin Zspin pour RL est selon vik facile à faire. Le problème se posera car le multi wheel ne sera pas compatible RL d'ou la nécessité d'un adoubement de Zspin par Djvj ^^

Avatar de l’utilisateur
XxTookie38xX
Initié
Initié
Messages : 114
Inscription : 22 juin 2014 - 01:00
A remercié : 2 fois
A été remercié : 1 fois

Re: [ZSPIN] Beta-test

Message par XxTookie38xX » 17 sept. 2015 - 22:13

metheore a écrit :
XxTookie38xX a écrit :
Porko a écrit :Zspin est un frontend, en gros il remplace hyperspin.exe il transmet les infos nécessaire à RL
Il n'y a pas besoin de le renseigner dans RL.

Pour l'installation il y a un WIKI en cours de rédaction https://github.com/HFScode/zspin/wiki


Pour répondre précisément à ta question il n'y a pas de module pour Zspin parce qu'il n'en a pas besoin prends le profil hyperspin
En gros touches à rien
Ok ça roule, mais du coup ça reste quand même tributaire d'hyperspin dans RL. Je vais essayer de plancher sur cette histoire de plugin et lancer un appel a djvj

Comme ça Zspin sera vraiment indépendant d'hyperspin

Nous avons essayé de contacté Djvj et sommes en attente de sa réponse.

Quoi qu'il en soit le plugin Zspin pour RL est selon vik facile à faire. Le problème se posera car le multi wheel ne sera pas compatible RL d'ou la nécessité d'un adoubement de Zspin par Djvj ^^
C'est ce qu'il me semblait. j'ai essayé de mon coté en renseignant en plugin ceux de hyperspin, ça fonctionne mais vu que zspin a pour but de s'affranchir de celui ci un adoubement avec RL est nécessaire.
Par contre en configuration multiwheel, ça risque de poser un souci, a moins qu'un acharné du code trouve quelque chose pour gérer ça au poil dans RL. (testé de mon coté, effectivement il reconnais bien mon xml du main menu, xml qui contient arcade consoles pinballs et Jukebox, et donc impossibilité d'utiliser a 100% les fonctionnalités de RL)

Avatar de l’utilisateur
Meth
Administrateur
Administrateur
Messages : 4396
Inscription : 19 oct. 2012 - 01:00
Localisation : Conflans-en-Jarnisy
A remercié : 880 fois
A été remercié : 1431 fois
Contact :

Re: [ZSPIN] Beta-test

Message par Meth » 19 sept. 2015 - 18:06

!!!!! MAJ 0.2.1 !!!!!


Je me fait messager du dev' :D, au programme:

0.2.1

* Load data from xml to api (available in html themes)
* Readme update
* Support new jswheel (more transformation options)
* Support building for arm7
* Fix pepper flash for linux
* Added/fixed languages



Pour info le chargement des données du xml dans les themes html doit être fait selon mes informations toute fraîche au seins du div du type:

<div class="zspin-genre"></div>

Au Htmlistes de se défoncer ;)

Avatar de l’utilisateur
Porko
Modérateur
Modérateur
Messages : 2018
Inscription : 02 févr. 2014 - 00:00
Localisation : 26700
A remercié : 249 fois
A été remercié : 378 fois

Re: [ZSPIN] Beta-test

Message par Porko » 19 sept. 2015 - 18:10

Yeah!!!

Bon qui pour le theme Aeon nox? Il y a tout ce qu'il faut maintenant

Avatar de l’utilisateur
JuL
Guide
Guide
Messages : 1941
Inscription : 17 nov. 2012 - 00:00
A remercié : 33 fois
A été remercié : 167 fois

Re: [ZSPIN] Beta-test

Message par JuL » 19 sept. 2015 - 18:36

Arm7, ça veut dire compilable pour raspi2 ?

Envoyé de la Lune en utilisant Tapatalk

Avatar de l’utilisateur
Meth
Administrateur
Administrateur
Messages : 4396
Inscription : 19 oct. 2012 - 01:00
Localisation : Conflans-en-Jarnisy
A remercié : 880 fois
A été remercié : 1431 fois
Contact :

Re: [ZSPIN] Beta-test

Message par Meth » 19 sept. 2015 - 18:37

Premier build oui jul. Il semble que ça lag pas mal pour l'instant.

Avatar de l’utilisateur
desfix
Gourou
Gourou
Messages : 503
Inscription : 31 mai 2014 - 01:00
A remercié : 13 fois
A été remercié : 20 fois

Re: [ZSPIN] Beta-test

Message par desfix » 21 sept. 2015 - 13:10

Juste pour savoir zspin sera compatible avec HL3 ou seulement avec rocketlauncher ?

Avatar de l’utilisateur
Porko
Modérateur
Modérateur
Messages : 2018
Inscription : 02 févr. 2014 - 00:00
Localisation : 26700
A remercié : 249 fois
A été remercié : 378 fois

Re: [ZSPIN] Beta-test

Message par Porko » 21 sept. 2015 - 13:17

Tout lanceur HL2, HL3, RL, many launcher...

Avatar de l’utilisateur
Odissine
Virtuose
Virtuose
Messages : 1217
Inscription : 20 févr. 2014 - 00:00
A remercié : 14 fois
A été remercié : 35 fois

Re: [ZSPIN] Beta-test

Message par Odissine » 21 sept. 2015 - 13:23

Ou juste RetroArch même ;) ...

Avatar de l’utilisateur
desfix
Gourou
Gourou
Messages : 503
Inscription : 31 mai 2014 - 01:00
A remercié : 13 fois
A été remercié : 20 fois

Re: [ZSPIN] Beta-test

Message par desfix » 21 sept. 2015 - 13:53

Parfait :) j'avais la flemme de passez a rocketlauncher :=)

Avatar de l’utilisateur
XxTookie38xX
Initié
Initié
Messages : 114
Inscription : 22 juin 2014 - 01:00
A remercié : 2 fois
A été remercié : 1 fois

Re: [ZSPIN] Beta-test

Message par XxTookie38xX » 21 sept. 2015 - 15:13

Dans le fond RL c'est pas différent de HL3, moi j'ai sauté le pas et j'en suis pas mécontent. Bien sur pour ceux qui veulent la bécane ultime c'est une vraie usine à gaz mais une fois pigé le système, on y va les yeux fermés


Envoyé depuis midgar, entre deux raids sur les réacteurs mako

Avatar de l’utilisateur
desfix
Gourou
Gourou
Messages : 503
Inscription : 31 mai 2014 - 01:00
A remercié : 13 fois
A été remercié : 20 fois

Re: [ZSPIN] Beta-test

Message par desfix » 21 sept. 2015 - 15:37

Ba quand tu fait la mise a jour de HL2 a HL3, franchement tu pas forcement envie de passez a rocketlauncher.
surtout quand ton système fonctionne déjà.
on verra sur le long terme.

Avatar de l’utilisateur
XxTookie38xX
Initié
Initié
Messages : 114
Inscription : 22 juin 2014 - 01:00
A remercié : 2 fois
A été remercié : 1 fois

Re: [ZSPIN] Beta-test

Message par XxTookie38xX » 21 sept. 2015 - 16:16

oui c'est vrai, j'avais se sentiment quand je suis passé de HL2 a HL3. Mais la franchement c'est vraiment intuitif. je te dis pas de passer absolument a RL (moi je l'ai fait dans l'optique de savoir maitriser une install de A a Z)

Avatar de l’utilisateur
slana54
Habitué
Habitué
Messages : 81
Inscription : 06 mars 2013 - 00:00
Localisation : 54840 - GONDREVILLE
A remercié : 12 fois
A été remercié : 1 fois

Re: [ZSPIN] Beta-test

Message par slana54 » 22 sept. 2015 - 10:37

Up

Personne d'autre que Vik pour répondre ?
Je me sent un peux seul.
J'ai le même message avec les sources de la version 0.2.1.

slana54 a écrit :Bonjour à tous,

Avant d’embêter Vik je voudrais savoir quelqu'un à réussi à utiliser le code source de Zspin parce que moi j'ai quelque pbs.
Pour infos: je débute avec Nodejs.

Quand j'essais d'installer les modules de package.json de la racine du répertoire zspin j'ai ce message:

Code : Tout sélectionner

> nslog@2.0.0 install C:\zspin\node_modules\electron-rebuild\node_modules\nslog
> node-gyp rebuild


C:\zspin\node_modules\electron-rebuild\node_modules\nslog>if not defined npm_con
fig_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\.
.\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node  rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYT
HON env variable.
gyp ERR! stack     at failNoPython (C:\Program Files\nodejs\node_modules\npm\nod
e_modules\node-gyp\lib\configure.js:116:14)
gyp ERR! stack     at C:\Program Files\nodejs\node_modules\npm\node_modules\node
-gyp\lib\configure.js:71:11
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:82:15)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\zspin\node_modules\electron-rebuild\node_modules\nslog
gyp ERR! node -v v4.0.0
gyp ERR! node-gyp -v v3.0.1
gyp ERR! not ok
npm WARN deprecated pangyp@2.3.2: use node-gyp@3+, it does all the things
/
> node-sass@2.1.1 install C:\zspin\node_modules\gulp-sass\node_modules\node-sass

> node scripts/install.js

Can not download file from https://raw.githubusercontent.com/sass/node-sass-bina
ries/v2.1.1/win32-x64-node-4.0/binding.node

> node-sass@2.1.1 postinstall C:\zspin\node_modules\gulp-sass\node_modules\node-
sass
> node scripts/build.js

gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYT
HON env variable.
gyp ERR! stack     at failNoPython (C:\zspin\node_modules\gulp-sass\node_modules
\node-sass\node_modules\pangyp\lib\configure.js:105:14)
gyp ERR! stack     at C:\zspin\node_modules\gulp-sass\node_modules\node-sass\nod
e_modules\pangyp\lib\configure.js:66:11
gyp ERR! stack     at FSReqWrap.oncomplete (evalmachine.<anonymous>:82:15)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\zspin\\node_modules\
\gulp-sass\\node_modules\\node-sass\\node_modules\\pangyp\\bin\\node-gyp" "rebui
ld"
gyp ERR! cwd C:\zspin\node_modules\gulp-sass\node_modules\node-sass
gyp ERR! node -v v4.0.0
gyp ERR! pangyp -v v2.3.2
gyp ERR! not ok
Build failed
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\
node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v4.0.0
npm ERR! npm  v2.14.2
npm ERR! code ELIFECYCLE

npm ERR! nslog@2.0.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the nslog@2.0.0 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the nslog package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls nslog
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\zspin\npm-debug.log

C:\zspin>
Mon deuxième pb c'est quand je veut zipper les fichier avant de renommer en .nw. Winzip me dis :

Code : Tout sélectionner

Nom trop long. Impossible à ajouter : "C:\zspin\node_modules\gulp-livereload\node_modules\lodash.assign\node_modules\lodash._basecreatecallback\node_modules\lodash.bind\node_modules\lodash._createwrapper\node_modules\lodash._basecreatewrapper\node_modules\lodash._basecreate\node_modules\lodash.noop\".
Nom trop long. Impossible à ajouter : "C:\zspin\node_modules\gulp-livereload\node_modules\lodash.assign\node_modules\lodash._basecreatecallback\node_modules\lodash.bind\node_modules\lodash._createwrapper\node_modules\lodash._basecreatewrapper\node_modules\lodash._basecreate\node_modules\lodash._isnative\".
En gros ce serais peut être bien d'avoir un petit tuto pour savoir comment utiliser ces sources.

ps: je suis sous windows 7

Avatar de l’utilisateur
vik
Connaisseur
Connaisseur
Messages : 404
Inscription : 01 janv. 1970 - 03:34
Localisation : Evreux
A remercié : 16 fois
A été remercié : 266 fois
Contact :

Re: [ZSPIN] Beta-test

Message par vik » 22 sept. 2015 - 10:43

vik a écrit :Alors:
Faut que je reteste de compiler sous windows, parce que la derniere fois que j'ai testé ya des trucs qui marchaient pas.
Et quand ca marche c'est censé faire tout tout seul (tout = lancer le truc en debug, regarder les changements sur les fichiers, faire les releases, etc).
et c'est atom-electron et plus nw (node-webkit) (mais on s'en fout on a pas a y toucher)

du coup ca sera fixé quand je fixerais le bug de compilation sous windows (cf https://github.com/HFScode/zspin/issues/11" onclick="window.open(this.href);return false;)
tu peux debugger toi meme si tu veux, mais la j'ai pas le temps de m'y mettre pour l'instant

Avatar de l’utilisateur
CyberBox
noob
noob
Messages : 4
Inscription : 07 oct. 2015 - 18:50

Re: [ZSPIN] Beta-test

Message par CyberBox » 07 oct. 2015 - 19:01

Quelle est la meilleur config pc pour faire tourne la zspin ?

Répondre

Revenir à « Releases »